Help

350Z

Moderators: Andy, Lyndon, BRONZEE, Z Club

Fraymoney
Posts: 4
Joined: Sat Mar 09, 2019 5:05 am

Help

Post by Fraymoney » Mon Mar 11, 2019 11:38 am

Hey guys I'm new to the site, I have a 2005 350Z and I have just had the engine light come on along with the VCD light and the SLIP OFF light as well does anyone know what this means? I have just left it in the garage for now and am using my other car. I haven't had a chance to have a really good look online but what I have come across hasn't been very helpful. Any advice or suggestions would be great.

Cheers Fraser

BRONZEE
Z Club Member
Posts: 7042
Joined: Sat Jul 08, 2006 5:41 pm
Location: Auckland

Re: Help

Post by BRONZEE » Wed Mar 13, 2019 1:39 pm

Fraymoney wrote:
Mon Mar 11, 2019 11:38 am
Hey guys I'm new to the site, I have a 2005 350Z and I have just had the engine light come on along with the VCD light and the SLIP OFF light as well does anyone know what this means? I have just left it in the garage for now and am using my other car. I haven't had a chance to have a really good look online but what I have come across hasn't been very helpful. Any advice or suggestions would be great.

Cheers Fraser
Hi Fraser,
It can be one of a few things. Your battery might be running low, and then it can start to upset the electronic sensors around the car. Or it might be your tyres?

Did you give it a bit of flipper when it light up the VDC and SLIP? Incorrect tyre sizing (rolling radius) and the compound of tyre can seriously upset the VDC, TCS, SLIP. Is yours a track or touring model? Did it go slightly into limp when it happened?

Also on here, search or look through the 350 technical section, "pedal dance" is what you're after. Timing must be perfect, but it will give you the manual fault codes to track down on google.

Can also flick a message up on FB, will pick it up there a bit faster. Both is fine though.
Next - Z Club events:
= A few events brewing to be announced =
= Christchurch meet brewing, details to follow =

Fraymoney
Posts: 4
Joined: Sat Mar 09, 2019 5:05 am

Re: Help

Post by Fraymoney » Sat Mar 16, 2019 6:45 am

Thanks for that, its a manual. What do you mean by flipper? I noticed the engine light while I was driving and it did sort of stall for a second but then carried on as normal which it has never done before. I think I will take to the mechanics and see what the computer says. I only use it on my days off so it doesn't get allot of use.

BRONZEE
Z Club Member
Posts: 7042
Joined: Sat Jul 08, 2006 5:41 pm
Location: Auckland

Re: Help

Post by BRONZEE » Sat Mar 16, 2019 4:14 pm

Fraymoney wrote:
Sat Mar 16, 2019 6:45 am
Thanks for that, its a manual. What do you mean by flipper? I noticed the engine light while I was driving and it did sort of stall for a second but then carried on as normal which it has never done before. I think I will take to the mechanics and see what the computer says. I only use it on my days off so it doesn't get allot of use.
Flipper = foot.

I wouldn't bother, it sounds like your tyres. Are they worn down? Running the wrong rolling radius, or both? What you've described is your traction control kicking in.

Much easier too, please put something logical in the Subject, makes it easier for others in the future with a similar issue.
Next - Z Club events:
= A few events brewing to be announced =
= Christchurch meet brewing, details to follow =

Fraymoney
Posts: 4
Joined: Sat Mar 09, 2019 5:05 am

Re: Help

Post by Fraymoney » Sun Mar 17, 2019 6:18 am

I have had the tyres on for about 2+ years and they would only just fail a warrant.

Fraymoney
Posts: 4
Joined: Sat Mar 09, 2019 5:05 am

Re: Help

Post by Fraymoney » Sun Mar 17, 2019 6:19 am

sorry I meant to say they have just passed a warrant but will need to be replaced before my next warrant is due.

Post Reply